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Introduction 
This user guide is dedicated to TEOS Manage, Sony’s solution offering a complete display device and room 

management solution for corporate environments that’s powerful, flexible and easy to use. 

 
TEOS Manage streamlines the control and maintenance of all your connected devices and content in 

boardrooms, meeting rooms, offices, reception areas, public spaces and other locations. 

 
This easy-to-use solution simplifies monitoring of the operational status of all networked displays, projectors 

and other devices via a friendly dashboard-style  

interface. Group devices by location for easier management. Schedule content playout and even create your 

own impressive digital signage in minutes. Integrate screens with  

 
our centralized bookings system to display meeting schedules in each room. Rapidly pinpoint issues with any 

device that isn’t working. 

 
Latest update enables organisations to move towards smart workplaces by allowing customers to control AV 

devices from their own smartphones, use tablets to book meeting rooms and create a virtual receptionist.
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Log-in for the first time 

To login in TEOS Manage, you can use your favourite browser and navigate to the TEOS Manage URL. By 

default, this URL is http://teos.manage, which we will use in this manual. It can be configured during TEOS 

Manage installation. 
  

  

 

Your administrator has created a username and password for you, which you can use to login in TEOS 

Manage. 

 
Fill in your credentials and click “Log In”. 

 
Please note that the first time you open and login to TEOS Manage, it can take some time. 
 
 

Forgot your password 
 

If you forgot your password you can use the “Lost your password?” option. When you click on this you will get 
the following screen: 
 

http://teos.manage/
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On this screen you can fill in your e-mail address and you will receive an e-mail to reset your password. 
 
 

Language Selection 
 
You also have the option in the Log In screen to already select your language. The available languages are: 
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Global overview dashboard 
 

After you log-in, you will see the following screen, which is called “Global Overview”: 

 

In the Global overview you can see the original Global overview which will display the devices in a device 
localization. Also if there are any issues for these devices these issues will be shown. 

Using the tabs in Global overview a user can go to: 
 

1. Dashboard 

2. Device statistics 

3. Room statistics 

4. Reception statistics 

5. Signage statistics 
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Device Statistics 
 

 
 
Device Statistics mainly show the Device usage, Energy consumption and Device types for a selected 
timeframe. 
 

Room Statistics 
 

 
 
Room Statistics will show the user the Meeting rooms usage, Energy consumption and Meeting room activity 
for a selected timeframe. 
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Reception Statistics 
 

 
 
Reception Statistics will show the Number of visitors and Reception activity. 
 

Signage Statistics 
 

 
 
Signage Statistics will show Signage usage, Energy cost and Most played presentations. 
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Top menu 
 
In the header section of TEOS Manage, you will have the following options: 
 

 

 

Search  
 

 
   

The Search bar gives you the option to search in Devices, Sites Configuration and Menu items. 

For example, you are looking for a Site Configuration called “TEOS” type “teos” in the search bar and click 

on the “Sites Configuration” tab. 

 

 

 

Alarms 
 

When you click on “Alarms”, you will be redirected to the Alarm configuration section. In that section, you can: 

 

• Create alarms by clicking the “Add alarm” button 

• See an overview of the existing alarms 
 

 
 

After clicking “Add alarm”, you can: 

 

• Fill in a logical name for the alarm 

• Select the alarm type: “Media” or” Signage content” 

• Select the groups where the alarm needs to be active in case you trigger it. 

• When you select the tick box “Add to quick menu”, the alarm can be triggered from the quick menu in 
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the header 

• When you have selected a group and chose to activate the “Allow interactive control” checkbox a 

“Show interactive URL’s button will be activated which will show you the start and stop URL’s for the 

device. 

 

Alarm quick menu 
 

The Alarm quick menu has been developed to activate alarms very quickly. The menu contains all the alarms 

where the tick box “Add to quick menu” has been selected. To open the quick menu, you need to hover your 

mouse above the alarm button and it will pop-up. 

 

 

 

If you want to trigger one of the configured alarms, you then need to press the run button. The alarm will be 

triggered on the group that is configured in the alarm itself. When you deselect the group and click the stop 

button, the alarm will stop and the devices will return to their normal state. 

 

Activate alarms on additional groups 
 

To activate the selected alarm on additional groups, you need to hover the mouse above the alarm that you 

want to activate. When you do so, you will see the default group selected and you can select the additional 

groups. 

 

 

 

Language selection 
 

To select your preferred language, click on the country flag you preferred. The default language is set to English. 

Other languages available are: Dutch, German, French, Italian, Polish and Spanish. Your preferred language will 
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be saved in your user profile. 

 
 

Log off 
 

In order to log-off, you can click the “Log off” button in the header. TEOS Manage will log you out and will 

return to the login page.
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Server Management 
 

 

In Server Management you have the following options: 

 

• Server dashboard 

• Settings 

• Alerts Management 

• Wizard 

• Back-up and Restore 

 

These options are meant for Administrators. Please refer to the “Server Management” section in TEOS Manage 

administrator guide. 
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Sites Management  
 
 

When you go to Sites Management in the TEOS Navigation menu you have the following options: 
 

• Sites Overview 

• Sites Configuration 

• Service Management 
 

Sites Overview 
 

This part of TEOS Manage is only accessible if you have the rights or has a specific pre-configured role. 

In Site Management you can create an easy overview where you can setup the complete structure of the 

company and also setup in which room which devices are available. You can also edit this structure easily and 

control the devices individually or for example turn on/off the power for a whole group.  

 

The pre-configured roles that have access are:  

• Administrator 

• Power User  

• Facility Manager  

• IT Manager  

• AV Manager  

An administrator can also create new roles and add these rights. So, if a user needs the rights to Site 

Management the administrator should be asked to provide these rights.  

  

To access Site Management, go to Administration in the menu options. It should be the first tab so you should 

already be in Site Management when you click on Administration.  

Else you should click on the tab Site Management.  

  

Overview  
  

It will show an overview. In our example the user will see the Company on the left, Site in the middle block and 

the Building on the right side.  
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Info 
 

To see info on how to use Site Management you can also always hover over the  (info button) 

 

How to setup a overview structure?  
 

1. Click the button. This will create a new company. There should always be a company to make 
a structure visible in the overview. 

 

 
 
If an Image or Logo is added then this will be displayed in the overview too. 
 
2. Once a company has been created this company block will show in the overview and you will be able to 

select it in the left dropdown. If you use right click on this company block you will be shown a few options:  
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3. You can Add, Edit or Delete a group. With Add a group you can add a (child) group to the company. It will 

automatically fill in the company as a parent. 
 
* It will never delete the complete structure. Only the device group that you delete. 
 
4. You can also do this on the created child group. This way you can easily create your structure. Just right click 

a parent to add the child group you want to add to this parent group. 
 
To make sure there is also still is a possibility to clean up or edit orphan groups that will not be displayed in the 
Site Management overview the user can also go back to “Device Localization”. 

 

Types 
 
1. Company 
2. Site 
3. Building 
4. Floor 
5. Room  

a. Meeting Room 
b. Desk 
c. Reception 
d. Restaurant 
e. Open space 
f. Closed office 
g. Common area 

 
There are two special rooms in the list: meeting rooms and desks. 
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Meeting room 
 

 
 
You have multiple settings in the Meeting Room tab. 

 

Settings 
 
1. Description, the description of the meeting. 
2. Capacity, the maximum amount of people that can be in this meeting room 
3. Check in time, the amount of minutes before the official start of the meeting that you can start a meeting. 

Make sure there is no meeting still going on. 
4. Cancel time, the amount of minutes after the official start time that a meeting is auto cancelled if not 

started in time. The room will be available for booking again. 
5. Incident mail address, when an incident is reported in the room with the TEOS Employee App this incident 

will be send to this e-mail address. An incident can only be reported when the meeting has started. 
6. Allow special services, if this option is checked then people are allowed to make special requests for a 

meeting room when using the TEOS Employee App, for example if they would like to have coffee during the 
meeting. 

7. Special services mail address, when special services are requested for a meeting these requests are send 
to this mail address. 

8. Equipment, this will display which equipment is available in this room when using the TEOS Employee App. 
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To add equipment to the list go to Administration -> Equipment Management. 
 

Content 
 
1. Room booking presentation 

the room booking presentation can be created in Workplace Solutions -> Room Booking in TEOS Manage. 
To add this Room booking presentation just select it in the Room booking presentation dropdown. This will 
add signage to the meeting room, so people can book the room using a TEOS Book tablet which is at the 
meeting room itself. You have to select it at the device in Device management if you want to make use of 
this Room booking signage: 
 

 
 
When selecting this option License type in Device settings has to be set on “Signage” or “Tablet”. The 
License type “Meeting Room” is meant for MRA. 
Meeting room device type has to be “Room Booking”. 
 

2. Meeting room calendar 
the calendar being used for the room booking. This can be an Office 365, Google or a TEOS Calendar. 

 
3. Room control presentation 

this is signage that can be added in Add-Ons in TEOS Manage and this will add TEOS Remote to the meeting 
room. You have to select it at the device in Device management if you want to make use of this Room 
control signage: 
 

 
 
Meeting room control 
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Device control 

 
 

Third party displays are only controllable using Simple Control license using basic IP connection. These will only 
show basic status on/off and you can only control the on/off and inputs functions on these displays. 

 

4. BRAVIA Meeting Interface 

To configure MRA from TEOS Manage. To create this configuration, you can go to Workplace Solutions -> 
BRAVIA Meeting Interface. For this you need the advanced MRA. The simple MRA installed on your BRAVIA 
will not work. 
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Desk 
 

 
 
 
For a desk you have less options than a meeting room, but it basically works like a meeting room. You can book 
a desk like a meeting room using an Office 365, Google or a TEOS Calendar. 
 
For a Desk you can create a stand-alone TEOS Calendar in Media and Data -> External Data. You can of course 
also choose to use an Office365 or Google calendar. 
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User Groups / Roles 
 
Setting these user Groups / Roles makes a meeting room only available to book using TEOS Manage for only 
the group of users who are allowed to book this meeting room. 
 

Status  
 
If you navigate back to Sites Overview you will see a dropdown with "Power status" in it. If you 

click on this you will see there are three options in the dropdown:  

  

   

 

Which devices in Power status overview?  
  

We have selected Power status in our example. This will show you the power status of the devices in the group.  

  

The values you will see in the Site Management overview for Power status can be different of what you are 

expecting. The overview will only show the devices of which the power status is known.  

Devices which don't return a power status are not counted in the overview. So the number in a block can be 

different to the amount of devices you will see when you click on a block to view the devices.  

  

Also devices that we never could connect to or players/tablets that don't have at least TEOS Control version 

1.16 installed are counted because we can't get the power status of these devices.  

 

Building, floors and areas  
  

We can click on the building block, in our example named "Main office" to go deeper in the overview. Now it 

will show you the Floors and Area's in this building.  

This can be different for you of course it just depends on how your administrator setup his device groups.  
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Navigation  
  

If you want to navigate back (to the upper level) then click on the most left block. In our example this is the 

building named "Main office".  

You can also use the CTRL+left mouse click and hold and drag the overview if the overview is to big for your 

screen.  

It is also possible to scroll or use the  button on the top right. 

If you want you can also zoom in and out when you use your scroll on your mouse on the overview.  

  

Status in Power Status 
  

When selecting Power Status you can see a the green status for the amount of devices that are powered on. 

The red status will show the devices that are powered off or have an issue like “no connection”. 

   

Devices in an area  
  

If you click on an Area block. In our example the meeting room "Test Meeting Room 1" it will show a popup 

with the devices in this Area:  

  

   

 

     Power off 

     Power on 
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     Not as expected / Device issue * 

 

* For example: Signage is scheduled but the display is on the wrong output channel. Or when the device never 

was connected. You can see if the device has a device issue in Global Overview -> Dashboard. 

 
 

Remote control for the displayed devices  
 

With the  remote icon in the devices popup you can go to the software remote (execute command):  

  

 
  

With this remote you can easily control your device remotely.  

 

Same as with room control third party displays are only controllable using Simple Control license using basic IP 
connection. These will only show basic status on/off and you can only control the on/off and inputs functions 
on these displays. 

 

You can see what Signage is playing on the selected device because Execute Command will now show a screen 
capture to the user. Not all the buttons might be supported for your device. The most important to remember 
is that you can’t switch of a TEOS Player. Because once switched of TEOS Manage will lose control over the 
TEOS Player. 

 

Device edit  
 

If you choose to click on the device in the devices popup you can go to the Device - Edit screen directly to 

change the settings for the selected device.  
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Meeting room status  
  

Next to the Power status overview you can also choose Meeting room status. This will display if a meeting 

room is booked or free to use.  

  

There has to be of course a Meeting Room that correctly has been configured. Once a meeting room is booked 

it will show a red status and if the room is free for booking it will show a green status. You can see this in the 

Site Management or if you go to menu item Administration and go to tab Device Management.  

  

If you go to the settings of the device and you go to tab "Meeting room settings" the options Frame size, 

Content and Signage Content have to be filled in.  
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Incident status  
  

The last option you can choose in the dropdown is Incident status. This will display the incidents for the 

devices. These are the incidents that are also displayed in Global Overview -> Dashboard.  

 

Sites Configuration 
 

In Sites Configuration you can find all the Device groups created within TEOS Manage. Also the orphan items. 
Items that don’t have a link with a company. You can only view this section if you have the rights to view this or 
if you are an administrator. Here you can also add, edit and delete Device groups. 

   

   
 

Service Management 
 

 
 
On the Service management tab you will see an overview of your devices. Here you can manually add a date for 
the “Warranty until” date. 

By clicking the access device logs button  you can access and download the device logs for a 
selected time span. 
 

Updates 
 
Within TEOS there also is an option now to update apps and firmware, download device logs and and option to 
remotely configure your device. These updates can also be scheduled. To be able to do this of course you need 
the rights or the right role. 
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In front of the device the following options might be available: 
 

Selection 

 Download Logs 

Update Firmware 

Update / install Android app 

Remotely configure device 
 

Selection icon 
 
This is to select one or more devices before you press the big download logs button in the top right of the 
screen. 
 

Download logs icon 
 
This is to download device logs from the specific device. 
 

Update Firmware 
 

This gives you the option to update firmware for a Sony BRAVIA using TEOS Manage. You need the latest *.pkg 
file from Sony to be able to do this.  
 

 
 

 
 
When installing this it will show you within TEOS when it is installing the firmware and will also show you when 
it is finished. On the BRAVIA itself you can see the progress of the installation. 
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Update / install Android app 
 

Here you can update your TEOS Android Apps on your device. (TEOS Android Player, TEOS Control, TEOS 
Connect) 
 

 
 

Test ADB 
 

This button is to check if there is a connection to the device and ADB installed on your computer. Sometimes 
you have to press cancel and press Test ADB again and if it still doesn’t work then there might be 2 issues 
possible. It might be possible that someone created an ADB connection outside of TEOS Manage manually 
which will not be very likely. The other thing that might be wrong is that ADB debugging is not activated on the 
Sony BRAVIA in settings -> developer options. 
 

 

 
 
The latest versions of the TEOS Apps should be selectable from the dropdown. If you have received a newer 
version you can also manually upload the newer version of the software. 
 
When you don’t want to install the update “Now” you can also select “Scheduled time”. 
 

 
 
Scheduling in the past is not possible. 
 
Once scheduled if you refresh the page you will see a number behind the Scheduled App Installations button. If 
you click on this button you can see the scheduled installations. 



 

 

29 | TEOS Manage user guide 

 
 

Remotely configure device 
 

 
 

 
 
TEOS Manage also now has a build in option to easily configure one or multiple BRAVIAs using an Excel script. 
In this script you can easily add steps to for example press UP DOWN LEFT RIGHT MENU etc.. The steps that 
you would do manually to set an option on the BRAVIA itself. Once configured you can use this script to 
configure multiple devices at once. When you run the script you can see on the BRAVIA if the steps run 
correctly. A factory reset before creating and then running the scripts is advisable. Because every screen needs 
the same starting point. Also remember that the Android version will make a big difference. 
 

Updates available 
 
In the overview you can also see if there is a newer version of software available. If the newer version is 
uploaded it will be available in the dropdown. A job will check after several minutes which devices can be 
updated. The software for these devices will highlight with orange text. 
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Administration 
 

 
The menu “Device Administration” offers you the following options: 
 

• Device Management 

• Equipment Management 

• Users Management 
 

Device Management 
 
On the device screen dashboard, you will see an overview of your connected devices and groups. 
 

 
 

Devices  
 
In the devices overview dashboard, you will see an overview of your connected devices. In this overview, you 
can: 
 

• Add devices 

• Auto discover devices in your network 

• Import excel to easy add a list of devices using a template 

• Change devices that you have selected 

 
The explanation on adding devices are handled in the TEOS Manage administrator guide.  
 

Reboot your devices 
 
It is recommended that you reboot your devices every day. You can do this using Actions Management within 
TEOS. Here you can add a daily schedule where you can add as an “Action Type” the action “Reboot”. You can 
set this for a specific device but also for complete device groups. 
 

Device Groups 
 
In the device groups overview, you can edit or delete device groups. When you select a device group, the 
devices overview will only show the devices that are configured in that group. 

 
*The TEOS Remote app is currently only available for Android devices 
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Devices actions 
 

In the devices list overview, you will see the list of all the devices that are added inside your TEOS Manage 

solution: 

 

In front of the device, you will see the following icons: 

 

      Edit device 
      Delete device  
      Execute command  
      Update device  

 
 

The items “Edit device” and “Delete device” are covered in the administrator manual. In this user manual, we 

will focus on the other elements. 

 

**A NFC tag can be written with a NFC writer app, or with additional Windows hardware 
 

Execute command 
 

This option allows you to send commands directly to the device. For scheduling please refer to “Actions 

Management” in this manual. When you click the “Execute command” button, a popup will appear: 
 

 
 
You can click on a button of that remote control and this command will be sent to the device immediately by 

IP. After sending the command, you will see a message beneath the remote control: 
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When you see this notification, it means the screen did respond and has executed the command properly. 

 

Update Device  

The update screen option  sends the last configuration to the device. For example, when you have 

changed the background of your meeting room screen, you can force the update by pressing this “Update 

screen” button. 

 

Preview 
 

The preview functionality is now built in the Execute Command in TEOS 2.0 as seen in the picture above. 

 

Signage Settings 
 

On the Signage Settings sub-menu, you can set the signage properties and create a schedule for each device 

specifically. A signage license is required on the device. There also is an option to select a default presentation. 

 

TEOS App Settings 
 

This area allows you to set-up your display standard TEOS Android application settings. 
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Rotation 
 

With the rotation setting you can rotate the canvas of the TEOS application, which is required for portrait 

device. The available options are 90 and 270 degrees rotation. 

 

Always in front 
 

With the “Always in front” option, the TEOS application will always be in the foreground. Even when a user selects 

an input manually, the application will always overrule. We recommend applying that feature for displays 

dedicated to signage. 

 

Default presentation 
 
When you click on the dropdown for “Default presentation” you can select a default  
presentation that will be shown on the device. 
 

Proof of play logging 
 

When you activate this option it will activate the Proof of play logging. This means a logging will be recorded for 
this specific device which will be visible in Content Creation -> Proof of play. This logging will be updated after 
every 100 pages played.  

 

Status 
 

The Status section gives you information related to the device’s status: 

 

 
 
In the status overview you have the following items: 

• Last Update - This displays the latest status update that is retrieved from the display 
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• Power Status - Power status shows the actual power status of the device 

• Volume Level - The actual volume level of the device 

• Current Input - Shows the input that is currently used on the device 

• Serial Number - Shows the device serial number 

• Model Name - Shows the model number of the device 

• Hours powered on - Shows the hours that the display is actively used 
 
 

Equipment Management 
  

 
 
Here you can add equipment that is available in a meeting room. This equipment will be visible in the TEOS 
Employee App. You can only add equipment if your local administrator gave you the rights for this or if you 
have a role that gives you these rights.  
 
If you add equipment you need to set a name and upload an icon that will be displayed for the meeting room in 
the TEOS Employee App. 
 

User Management 
  
To be found in the TEOS Manage Administrator Guide. This option is only meant for Administrators. 
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Workplace Solutions 
  
 
The menu item Workplace Solutions contains 7 items. 

 

• Signage 

• Room Booking 

• Room Control 

• Receptions 

• Class Check-in 

• Survey 

• BRAVIA Meeting Interface 
 

Signage 
 

New presentation 
 

To create a new presentation you require the following items to be created: 

 

• A template 

• A page 

• A playlist 

 
How to create a template, page and playlist is described in the chapter Content Creation. If you have done this 

correctly it means we can start creating our presentation. In TEOS Signage Designer, click Content > 

Presentations [Content > Presentations] and then on the New presentation button. 

 

 
 
Enter a name for your presentation and select a resolution. If you have created a masterpage, select the 

appropriate masterpage from the menu. 
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Next, select a playlist – in our case, this is My first playlist. 

Click the symbol and select a playlist: 

 

 
 

Your content is almost ready for use; all you need to do is send this content to a device as explained earlier in 

this manual. 

 

Mail to signage 
 
You can specify a mailbox here from which PowerPoint (.ppt/.pptx) attachments will be read and automatically 
converted to signage content. The current presentation will then be replaced with this signage content. With 
the “Number of minutes between mailbox checks” it is possible to set the sync time. 

 
 

 
 

Room booking 
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Create room booking 
 

To create a new Room booking click the  button. This will open the following screen. 
 

 
 
Fill in Name and select a Template. Selecting Everyone means that everyone can start, extend and stop a 
meeting. Organizer only means that only the Organizer can do this using RFID. After clicking Save you will go to 
the following screen. 
 

 
 
You can assign the room booking template to a meeting room using “Assigned Meeting Rooms” and click on the 

 .  
 
If you would go to Sites Management -> Device Localizations and you select the meeting room you will see the 
same Presentation and Calendar have been added to the meeting room. 
 



 

 

38 | TEOS Manage user guide 

 
 
Once added a name and saved you can edit the template if you would like. Next to text editing you can also add 
multiple room bookings to the template. You do this by double-clicking the “Find another room” button and go 
to the tab Behaviour. 
 
At the bottom you will see the option “Other rooms”: 
 

 
 
You will see the default room booking and next to it you see the + button. If you click on this + button you can 
select and add multiple rooms. These will show once a user will press the find another room button on the 
room booking tablet. With this functionality you can make it possible to check on a TEOS Book that is connected 
with a meeting room if another room is available when the room is already booked. 
 

Meeting room calendar 
 

This depends on which calendar type you are going to use. You can select a TEOS Calendar directly but you can 
also add a calendar that is created in Media and Data -> External Data. This is meant for calendars for Office365 
and Google. You have to set up calendars in External Data first before you can use them. You can also manually 
add a TEOS calendar in this section. 
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Room Control 
   
 In TEOS Manage If you go to Add-Ons and select the tab Room Control you can create a new remote control 
(TEOS Remote) that can be used for a meeting room.  
 
First click the button:   

 
 
Here you can create your TEOS Remote that you can use In the meeting room. 
 

 
   
 Then go to Administration In the main menu and go to Site Management (or If you rather use the old way go to 
Sites Configuration). In Site Management lookup the meeting room that you want to add TEOS Remote to. 
Right-click this meeting room and click "Edit". If you go to the Meeting Room tab you have to add the created 
"Room control presentation". Just select the Room Control presentation that you created. 
 

 
 
When you connected your Room Control presentation to the meeting room you have to go to Administration -
> Device Management.  
 
Then select the device In the Meeting Room that you want to use as a TEOS Remote. Most of the time this will 
be a tablet.  
 
Go to the Meeting Room Settings tab for this device and In "Meeting room device type" select "Room Control".  
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Now your tablet should show you the devices In the room that can be remotely controlled by TEOS Remote. 
 

When having more than 3 devices in the meeting room 
 
With the standard TEOS Remote template there are 3 Devices that are shown. If you want to display more than 
3 In TEOS Remote go back to Add-Ons -> Room Control.  
 
Click on the name of your TEOS Remote template. Then click on the "RoomControlMain" page at Pages. 
When you opened the template double-click on the 3 devices part of the template.  
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This will open the following popup: 
 

 
 
Here you can select "Device Icon size". "Big" can display 1 device. "Medium" can display 3 and "Small" can 
display 10 devices. 
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Receptions 
 

Receptions 
 

With the TEOS Reception module, you can welcome visitors and notify the person they are visiting by e-mail or 

SMS. Currently the SMS services of Spryng is integrated in TEOS Manage. To send messages through Spryng you 

will need an account, more information can be found here: 

 

http://www.spryng.nl/en 

 
 

TEOS Reception will query all the users from the TEOS Manage database so it is important to fill in the 

mobile numbers and the e-mail addresses of the persons that are in the TEOS manage database. 

 

TEOS Reception settings 
 
For Administrators a new section is added in Server Management -> Settings to easily configure the TEOS 
Reception settings. This will be explained in the TEOS Administrator guide. 
 

TEOS Reception Add-on for Outlook 
 
For now TEOS only supports Office365/Outlook. To add the TEOS Reception Add-on in Outlook you have to 
follow the next steps: 
 
1. Go to file in your regular Outlook menu 
2. Click Add-ins 
3. Login into the browser in Outlook 
4. Go to General -> Add-ins 
5. Click +  
6. Select add using URL 
7. Fill in your domain name followed by /outlookaddin/TeosReception.xml. For example if your domainname 

would be https://teosmanage.com you will have to fill in 
https://teosmanage.com/outlookaddin/TeosReception.xml 

8. Go back to your regular Outlook. The TEOS Reception Add-on should now appear in the action bar in the 
top on the right. 

 

http://www.spryng.nl/en
https://teosmanage.com/
https://teosmanage.com/outlookaddin/TeosReception.xml
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You should now be able to invite people for TEOS Reception. These people will be send a code by mail that they 
can use when they are arriving at your company. When they select they have an appointment they have to fill 
in this code. The person who invited will receive a message then the person arriving filled in this code when 
activated for the TEOS Reception template. 
 

 

Create a new Reception 
 

To create a new reception, you need to navigate to “Content creation” and select “Receptions” from the top 

bar. 

After that, you need to click  and fill in the logical name and select a template of your choice. If 
wished this template can be adjusted by clicking on the pages after creating a reception. If you wish to print a 
visitor badge select the correct printer*. The printer needs to be installed on the TEOS Manage server. 
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SMS 
 

If you wish to notify the person who is visited by SMS, you need to tick “Send SMS notification”. The configured 

Spryng SMS service will be used automatically.** 

The default number is used when the visitor has no appointment. 
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E-mail 
 

If you wish to notify the person who is visited by e-mail, you need to tick “Send e-mail notification”. The e-mail 

addresses of the users in TEOS will be used automatically, however your administrator needs to configure an 

SMTP server for sending e-mails. The default e-mail address is used when the visitor has no appointment. It is 

also possible now to setup the invitation and reminder e-mail. 

 
 

* currently TEOS Manage only supports Dymo badge printers and the layout can be done in the Dymo studio 

 

** Please ask your administrator to configure the Spryng SMS service. The manual on adding  Spryng SMS is 

available. 

 

Printing badges 
 
A new tab has been added to Content Creation to create a badge that can be printed for the visitor. 

 

You can add text, images, rectangles, date/time and QR code functionality to the badges. If you insert the text 

#VISITORNAME# it will replace the text with the name of the visitor. You can also automatically insert the 

contact name by inserting the text #CONTACTNAME#. 

 

 
 

 

Class Check-in 
 
Class Check-in is a check-in system that requires a TEOS tablet with an RFID card reader (TEB-RFID). This system 
can check if a person is allowed to join a class session when using his or her card to check in at the RFID.  
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To setup Class Check-in go to Add-Ons and go to the Class Check-in tab.  
 
Next click button: 

 
 
This allows you to create a new Class Check-in. 

 
 
Here you fill in your Calendar URL and Checkin URL. TEOS Manage does a call on these customers URL’s and 
expects an answer back. 
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Survey 
 
In Add-Ons also Survey tab has been added. When you click on this you can add a survey to a touch display or 
tablet. To do this first click the button: 

 
 
Here you can give the Survey a name and you will be able to add it as Signage to a device. You also want to 
select the template that you would like to use. When you done this click save.  
 

 
 
You will now see your Survey in the Survey tab. 
 

 
 
If you click on the name of the Survey you will see the Pages of the Survey. If you click on the name of the Page 
for example you can edit it. In the “Survey Start” page you can change the question by double-clicking on it. 
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When you are set you can add it as signage to the display you want to use. When people will tap on the smileys 

the results will be saved in Add-Ons -> Survey. When you click the button you can export the data of the 
Survey. 
 

 

BRAVIA Meeting Interface 
 

BRAVIA Meeting interface (MRA) 
 

A new section for BRAVIA Meeting Interface has been implemented to configure MRA using TEOS Manage. 

After setting it up you can assign the created BRAVIA Meeting Interface to a meeting room in Site 

Management -> Sites Configuration -> Edit/Create meeting room. 

 

Input configuration 
 

On the input settings area, you can give a label to an input, in order to make it logical: PC1 to HDMI1. You 

can just type the text and the display will show that name instead of HDMI1 also you can add a logo. You 

can do this for 4 HDMI ports. 
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Meeting Room Title 
 

On the title settings, you can insert or edit two lines of text that will appear on the display, in order to make 

the name of the meeting room visible to everyone. 

 

 

 

“Help Page”-content 
 

To add customized text to the ? in the menu op MRA on the display. 

 
Content 

 

In the content area, you have multiple options to get content on your display. 
 

Frame size 
 

With this option, you can decide whether you want to show the selected content in full page, bottom half or 

none at all. 

 
You can additionally choose one of the following content options: 
 

• On manual input 

• Webpage URL 

• Outlook (Office 365 & Exchange calendars) 

• Google (Google Calendar) 

• Signage content* 

 

Content (dropdown) 

 

In the content dropdown you have 4 options: 

 

• On manual input 

o The display is used with one of the inputs such as HDMI, as background. 

• Webpage URL 

o You can show a webpage by inserting the URL of the website. It will be become the 

standard background of the meeting room screen. 

• Meeting schedule 

o To add the meeting schedule to MRA. You will see the nearest upcoming appointments on 
the display. 

• Signage content 

o To display signage in MRA. 
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Background colour 
 

The colour of the background that you want to use 

 
Background transparency 

 

The transparency of the background. For example, when you are using a background image and the Outlook 

information is on, you can still set transparency. 

 

Text colour 
 

The text colour of the outlook appointments 

 
Time colour 

 

The colour of the scheduled time 

 

Description colour 
 

The colour of the appointments descriptions 

 

Web page URL 

 

To set the URL for the webpage you want to display within MRA. 

 

Signage Content 
 

You also can show signage content on the display and select an existing content. To do so, you will need a 

signage license. 

 
Select Signage from the dropdown menu and then select a presentation from the signage content menu. Please 

refer to the “Signage” section in this manual to learn how to create signage content. 

 

Background image 
 

With the “Background image” option, you can choose an image that will become the display’s Meeting Room 

interface background. 
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Associated Devices and Device Groups 
 

Add device or device group 
 
Click the Add device or device group button to add a meeting schedule to a device or a device group. 
 

 
 
The Meeting Schedule dropdown will display all the calendars. (TEOS, Office365 and Google) 
If you have set this and you have set the Content dropdown to Meeting schedule it will show the appointments 
in the calendar in MRA. 
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Schedules and Alarms 
 

 
In the Schedules main section, you can schedule signage content and configure power schedules. Here you 
have the following options: 
 

• Content Schedules 

• Actions Schedule 

• Alarms 

• Meeting Schedule 
 

Content schedules 
 

In this area, you can schedule signage content, media or an URL to device groups on specific times and dates 

using a user friendly calendar. 

 

 
 

By default the “Agenda” overview is selected. The supported views are: 

 
• Day - The day view shows all scheduled items for this specific device per day 

• Week - The week view shows all scheduled items for this specific device per week 

• Work Week - The Work Week view shows all scheduled items for this specific device per work Week 

so Monday until Friday 

• Agenda - The Agenda overview shows scheduled items in a list view 
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Group filter 
 

On the left side, you will see an overview of the groups. Every group has its own colour so that you can easily 

recognize them in the schedule overview. When there is a schedule active on the device, you will see an item in 

the schedule overview in the group colour. 

 
On the left side, you will see a device schedule. On the right side, you will see a group schedule: 

 

 

If you want to filter a group, you need to select the group by clicking on it. Then, please click on “Filter”. 

 
 

 

Create a schedule 
 

In our example, we used the week view. If you want to create a group or device schedule, you can select a 

period by holding your left mouse button and drag down or right until you have selected your preferred 

schedule time. After that, please right click on the area you have selected. It will allow you to choose “New 

Schedule”: 
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In the “Device” field, you can choose a device on which scheduling will be applied. If you prefer to apply it on a 

group of devices, please go to “Device Group” field. In the “Name” field, you can insert the name of the 

schedule. 

In the “Content” field, you can select the content (media, URL or signage) you want to schedule. 

When you tick the “Recurrence” box, you can edit the recurrence properties: 

 

 
After setting your preferences and content click the “Save” button. Your schedule will be directly shown in the 

calendar: 
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Action schedules 
 

Action schedules are used to schedule devices in your environment. In the overview, you will see all 

configured power and action schedules. 

 

 
 

Power Schedule 

 

To create a new power schedule, please click the button “Add action schedule”. The screen contains the 

following items: 

 

 
 

 

• Name - Insert a logical name, for example “Meeting Room 1 – Power schedule” 

• Action Type = Power 
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• Repeat - Repeat is used for recurrence settings. For example if you want to power on every day. 

• On - The time that the power schedule needs to start and the devices to switch on. 

• Off - The time that the power schedule needs to stop and the devices need to switch off. 

• Forced – When checked it has priority over all other schedules except alarms. Alarms will always 
have the highest priority. 

• Device localization - The power schedule will be active on the selected group(s) 
 
There are 2 types of power schedules. A non-forced power schedule and a forced power schedule. You can 
only created a forced power schedule when you entered an “On” time and an “Off” time. 
 
Example 
 

If you want to power on your displays every day between 09:00 and 12:00 then select: 

 

• “On” 

• Start 09:00 

• Stop 12:00 

• In the repeat section you select “daily” and ends “never” 
 

Priority schedules  
 
The priority with power schedules: 
 
1. Alarms 
2. Forced power schedules 
3. Action schedules 
4. Content schedules 
5. Non forced power schedules 

 
If there is another schedule or the device is playing Signage and you created an action schedule that should 
turn the device off it will not work. It will switch on again because it wants to play the signage. If you really 
want to turn the devices off the best thing to do is to create a forced power schedule. Unless you have a 
device that has no content playing or nothing scheduled. 

  

Action Schedule 
 
In the Actions Schedule section, you can schedule the commands you want to send to devices. 

Available commands for displays are: 

• Power 

• Reboot 

• Install updates 

• Start Signage 

• Meeting Room application 

• Volume 

• Mute 

• Channel Up 

• Cannel Down 

• Channels 
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• HDMI1 

• HDMI2 

• HDMI3 

• HDMI4 

• Input PC DVI 

• Input PC Dsub 

 

 

You can start creating a command by clicking the button: 

 

 

After clicking that button, you will see a new window with the following options: 
 

 
 
In our case, we defined an action to start the “Reboot Test Device“ during weekdays at 7:00 AM to device 

“Reboot Test Device”. You can also select a Device Localization (group) if you prefer. 

 
When you are finished, please click the “Save” button. Your command will be saved and scheduled. After that you 

will be redirected to the Actions Management overview screen where you can edit or delete the schedule: 

 

 
 

Make sure the schedule is set on “Active” else the action will not be executed. 
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Alarms 
 
See topic Top menu 
 

Meeting Schedule 
 

 
 

Create calendar 
 

Here you can create a new schedule by selecting the date range by clicking or dragging the mouse over the 
agenda while holding the left-mouse button. On the left side you will see the meeting rooms. After selecting 
one and clicking on the Filter button it will only show the schedule for the filtered meeting room. 
 
If you release the left-mouse button you can click with the right-mouse button to select one of the following 
options. 
 

• New schedule 

• Today 

• Go to date 

• Settings 
 

When you choose “New schedule” the next screen will be shown. 
 

 
 
You can add the schedule to a Meeting Room and add a start and stop date and time. 
 
Meetings scheduled using TEOS Room Booking or the TEOS Employee App will also be shown in the meeting 
schedule. You are not allowed to schedule when there already is a schedule on the selected date and time. You 
will receive the following error message: 
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Refresh calendar 
 

The calendar is refreshed at the moment you navigate to the calendar. If you are already on the calendar page 

and you want to make sure you have the latest data on your screen you can press the  
button. 
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Content Creation 
  
 
The digital signage can be fully managed and configured using your web browser. This section is designed to 
assist you in a user-friendly way to operate TEOS Manage signage and to publish content easily. 
 
Before starting with Content Creation please read a little further to see the Content Creation workflow. 
 
In Content Creation you will find the following tabs: 
 
To create Signage: 
 

• Masterpages 

• Templates 

• Pages 

• Playlists 
 
To create Printing badges for Receptions: 
 

• Printing Badges 
 
Other: 
 

• Content log 

• Proof of play 

• Resolutions 
 

 

Functionalities of TEOS Manage signage 

In this area, you can schedule signage content, media or an URL to device groups on specific times and dates 

using a user friendly calendar. 
 

Functions 

Video upload v 

YouTube v 

PDF integration v 

PowerPoint integration v 

Twitter integration v 

Instagram integration v 

Facebook integration v 

Websites v 

Streaming Video v 

Streaming Audio v 

Weather feed v 

Dynamic text v 

External data [RSS/XML] v 
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Media RSS v 

Local caching * v 

Ticker tape v 

Plan module (scheduling) v 

Bandwidth-efficient ** v 

Monitoring v 

Touch functionality v 

Interactivity v 

Offline mode v 

 

* Local caching is used to retrieve data from the server and save it to the local display. It is meant to ensure 

that content can still be displayed even when your network connection is down. Note: this does not apply to 

services such as audio and video streaming. 

 

** The player is bandwidth-efficient because the data is retrieved from the TEOS Manage server only once. 

The Android application does not need to retrieve the content from the server on each separate occasion, 

making it bandwidth-efficient. 
 

 

Content creation workflow 

Before you start creating a presentation, the following scheme explains the signage content creation 

workflow: 
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Masterpage
(optional)

Content Creation  -> 
Masterpages

Template(s)

Content Creation -> 
Templates

Presentation
(with or without 

masterpage)

Workplace Solutions -> 
Signage

Page

Content Creation -> Pages

Page

Content Creation -> Pages

Page

Content Creation -> Pages

Playlist

Content Creation -> Playlists

Playlist

Content Creation -> Playlists

 

 
The presentation represents the final content you would like to display on a screen or multiple screens: 

• The presentation itself is made up out of one or multiple playlists. 

• A playlist contains pages. 

• These pages are based on 

• Your corporate identity is guaranteed in the masterpage; this special template holds your company 

logo and elements in your corporate style and/or colours, for example. 
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Available elements 
 

 
 

Below is a list of the elements available in TEOS Manage Signage Designer – these are used to create templates 

and master pages. 

 

 Selection tool 

 Text element 

 Image element 

 Video element 

 Graphics element 

 TV element 

 Website element 

 Ticker (scroll) element 

 Date/time element (Formatted text) 

 YouTube element 

 Vimeo element 

 Audio element 

 NU24 element 

 Slideshow element 

 QR-element 

 Meeting room element 

 Remote control 
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 Survey 

 PowerPoint element 

 

Element explanation 
 

  Selection tool 

 

  Use the selection tool to select an element from your presentation. 

 

  Text element 
 

Use the text element to add text. The dialogue box will ask you to enter a name (your own description) and 

text. The [Formatting] tab allows you to enter the font, size, colour, style and transparency. You can also 

retrieve the text from an external data source, for example CNN. To do so, click on the ‘Data’ tab, and under 

[External data], select the data source you would like to use. The ‘External data’ section in this manual 

explains how to create data sources. 

 

  Image element 
 

The image element allows you to add images. The dialogue box will ask you to enter a name (your own 

description). On the [Formatting] tab, you can select measurements and transparency; choose whether to 

keep or to change the current ratios; and select the appropriate alignment. 

 

You can upload one from your computer on the ‘Data’ tab by clicking [Add  

file(s)]. Once you have added files, you must click the [Start upload] button. The image will then appear in 

your media library. You can also retrieve images from an external data source, for example Yahoo Weather. 

To do so, click on the Data tab, and under [External data], select the data source you would like to use. For 

instructions on how to create data sources, check the ‘External data’ section in this manual. 

 

  Video-element 
 

The video element allows you to add a video that has been uploaded from your local file, or, alternatively, 

you can insert a Streaming URL in order to display live images of a camera (for example). You can do this by 

selecting a video on the ‘Streaming’ tab. The ‘Data’ tab allows you to 

 

select or upload videos. You can upload videos from your computer on the ‘Data’ tab by clicking on Add 

file(s). Once you have added files, you must click the Start Upload button. The video will then appear in your 

media library. 

 

 Graphics element 
 

Use the graphics element to draw items in your template or master page; it is used, for example, to draw a 
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background behind a ticker tape. You can select a colour from the Layout tab. 

 

 TV element 
 

Show source of your TV. Only html5 not Android. 

 

  Website element 
 

The website element allows you to display a website. You must enter the complete URL on the ‘Data’ tab. You 

can select ‘Reload’ as an additional option; the page will then be refreshed each time. 

 

  Ticker tape element 
 

The ticker tape element allows you to add a scrolling text overlay (crawler). The dialogue box will ask you to 

enter a name (your own description). The Layout tab allows you to enter the font, size, colour, style and 

transparency. In addition, you also have the option to retrieve the text from an external data source, for 

example NOS [Netherlands Broadcasting Foundation]. To do so, you must click on the ‘Data’ tab and, under 

External data, select the data source you would like to use. To create data sources, you must read the 

instructions contained in the ’External data’ section of this manual. Additionally, you can enter your own 

text in the ‘Data’ tab. 

 

  Date/time element 
 

The date/time element allows you to add a date and/or time. On the Layout tab, enter the font, size, colour, 

style and transparency. The Data tab allows you to select the format, HH:MM:SS or DD- MM-YY. 

 

  YouTube element 
 

The YouTube element allows you to add YouTube videos – for this you require the URL or code for your 

video. For example, you can copy the URL from your browser. You must then paste the 

YouTube code/URL onto the ‘Data’ tab and decide whether you would like to play all or part of the video. 
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 Vimeo element 
 

Same as YouTube only for Vimeo. 

 

  Audio element 
 

Use the audio element to add single sound files or add an audio stream. 

 

  Slideshow element 
 

It’s very easy to create an image slideshow using the Slideshow element. By linking to images from the 

image database, you can compile your own image sequence. You can also set the interval between slides 

and choose to make the images semi-transparent. 

 

  QR-element 

 

TEOS Manage Signage allows you to create QR codes within your templates and pages. Simply select the QR 

element tool and draw the size of your QR element which you prefer. Keep in mind that a QR element will 

always be square; which means you aren’t allowed to change its 

measurements . Once you have placed the element on your template, you now only need to fill in the URL 

which you want to trigger when the QR code is being scanned. 

 

  Meeting Room-element 
 

With the Meeting Room-element you can create content for meeting room tablets such as the TEOS Book 

TEB-10DSQPL. 

With this element, you can create your own styled meeting room application which can be used for starting, 

stopping, extending and creating meetings on the fly. The meeting room element will automatically update 

your connected calendar. The supported calendars are Google Calendar, Office 365 calendar and Exchange 

server calendar. Information about how to connect a calendar can be found in the section “Connecting 

calendars to the meeting room element with External- Data”. 

 

Meeting Room-element configuration 
 

In the TEOS Manage content creator, you can create your own styled meeting room 

templates. To do so, you select the “Meeting room-element” and draw in the template. After 

that, a popup will appear. 

In the pop-up you need to fill in a name. The most simple setup will be: Start, Stop, Extend, 

Create or status. If you click the tab “Behaviour”, you can select one of the types: Start, Stop, 

Extend, Create or status. 
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All items need a button except for status. When you have selected one of the types (with exception of status), 

you can select or upload a button image and select the appropriate calendar. You can repeat this step for all the 

items you want to use in your template. 

Status however is used to show the status of the meeting room display and can also control the LED’s of your 

TEOS Book device. 

To use the status, draw a shape in the template with the meeting room tool and fill in a name, for example 

“status”. Select the status option on the “Behaviour” tab. On that tab you will see: 

 

  Remote control 

 
To add remote control functionality to the masterpage or template. You can make this visible to set the button 

image in the behaviour tab.  

 

You can select a remote control type: 

 

• Remote control button 

• Device list 

• Back button 

 

  Survey 

 
  To add a Survey to your masterpage or template. 

 

  PowerPoint-element 
 

From within a masterpage or template, you can easily upload your PowerPoint files. TEOS Manage will 

automatically detect the amount of pages and will ask you if you want to use them as single images (by using 

the slideshow element) or as a video file. 

 

 

Creating signage content 
 

Masterpages 
 

Masterpages are pages containing specific elements, for example a news ticker tape that must appear on every 

page of the presentation. You might describe it as a layer that is applied across all the pages of the 

presentation. An example of the application might include: 

You would like to use the same background using an NOS news ticker tape throughout your presentation. You 

can then create a masterpage by navigating to [Content > Master pages] in TEOS Manage Signage Designer and 

clicking the “New Masterpage” button. 

 

 
 

A new screen will now appear where you can enter the name of your masterpage and select the required 

resolution. 
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Next, a screen will open on which you can select elements, for example a background image and a ticker tape. 

 

Templates 
 

In the Designer, click ‘Content’ and then ‘Templates’. In the template section, click on New template. 

 

Enter the name of the template you would like to create, select the required resolution and click Save. 
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The following screen will appear: 
 

 
 

 

In the template designer, you can select one of the elements that appear in the menu bar. 

If you click on the element you would like to place in the template, use your mouse to start drawing in the 

white window by right-clicking on your mouse and drawing the required dimensions. Once you have 

completed this, a window will open: (we have drawn an image in this example). 

 

 
 

You must enter a number of data in the window, including the image name. This name must be understandable 

to you and will not be displayed in the final presentation (only on the overview of elements on the left-hand 

side). 

 
The Layout tab allows you to select a number of options relating to how the element is formatted. For images, 

you have the following options: 

 
• Stretch; Fill:[Ratio is not maintained] 

• Stretch; Uniform [Ratio is maintained] The option Stretch; Fill is  

 selected by default. 
 



 

 

71 | TEOS Manage user guide 

From the ‘Data’ tab, you can select a previously posted image, or, alternatively, you can upload one from your 

computer by clicking New upload. Next, click on the image to select it and then click on Save to insert the 

image. We have added a second image to the example (on the left-hand side), called ‘Image’. 
 
 

Next, in the template we can select, for example, a text element and add this: 

 
The template is almost ready for use; we might still choose to add a ticker tape showing CNN news items. As 

explained above, we can use a ticker tape to be used on the master page or we can insert it into this template. 

For now, we are going with the second option. 

 
Click on the ticker tape element and draw a ticker tape in the black bar at the bottom. Next, give the 

element a name, for example ‘CNN ticker tape.’ On the Formatting tab, select font size 60 (this is standard) 

and the colour white. On the ‘Data’ tab, select CNN and ‘title’ as the column, then click Save. The title column 

from the CNN RSS feed is now displayed, in white and with a font size of 60. Click on Save at the top of the 

page – your template is now ready for use. 

 

Pages 
 

Pages are based on templates. You can use one of the predefined templates for this purpose, or, 

alternatively, you can use a customized template. In this example, we use the “manual” template. To create a 

page, click on Content > Pages in TEOS Manage Signage Designer and then on New page. 

 

 
A screen will appear in which you must enter the name of the new page. In this page we will use the name 

My first page. Select a template and click Save. 
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The next page will open: 

 

 
 

By clicking on an element on the left-hand side, under Elements, you can make changes to your text or images. 

However, you can no longer change the positions of the elements – this is possible only in the template. Once 

you are done editing a page, click Save. 

We would now like to add our page to a playlist; to do this, we need to go to the ‘Playlists’ section.  
 

Playlists 
 

Playlists contain pages including information you would like to display on screens. A final 

presentation may contain multiple playlists, for example if you have installed a screen in the cafeteria and 

would like to display the menu along with general information. In that case, you can select a playlist containing 

both general information and menu information, in order to prevent menu information from being displayed 

on screens where it does not belong. To create a playlist and add pages, you must click on Content > Playlists in 

TEOS Manage Signage Designer and then on New playlist. 

 
 

You enter the name of the playlist, select the required resolution and click on Save. 
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A new screen will appear displaying all the pages that are available in the same resolution. 
 

 

Next, click on the page you would like to add, then click on Add to timeline. 

The page will now appear below at the bottom of the timeline. You can select the duration by dragging the 

page on the right-hand side to the right. For example, if you would like to display the page on the screen for 20 

seconds, you should drag the page (enlarged) to 20 seconds, or, alternatively use the ‘-’ and ‘+’ buttons. Once 

you have added the page(s) required, click Save and continue to the ‘Creating presentations’ section. 

 

Content Log and Proof of Play 
 

Content log 

 

 

 

In Content log you can see all the changes being made on content. You can search based on: 

 

• User, type in the username or a part of the username. (not case sensitive) 

• Content Name, type in content name or part of the content name. (not case sensitive) 

• Start date / End date, select within 2 dates. 

• Content types, to filter based on the content type. (multi selection possible) 

o Masterpages 
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o Templates 

o Meeting Room Templates 

o Pages 

o Playlists 

o Presentations 

o Media 

Proof of play 
 
This shows an overview to the user of the pages shown. 

 
 
Make sure the Proof of play logging is checked in Administration -> Device Management. When you edit (or 
create) a device go to the Signage settings and check the Proof of play logging checkbox. The first time it will 
take 100 pages first to be played before you will see the logging. 
 

 

Resolutions 
This section contains the standard resolutions for creating Signage and also gives the user an option to add a 
custom resolutions. 
 
These resolutions can be selected when creating masterpages, templates, etc. 
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Media and Data 
  
 

Media Upload 
 

The media library is used to store the media that you want to use in your environment. In the media library, 
you can create folders, upload and delete media files. You can also set the rights to make media available or 
blocked for specific users. Administrators will always have the rights to view or delete all media and folders. 

 
 

If you want to create a folder click the  button. 
 

After that you can click the folder name and click the  button. Then click the browse 

button to select media files that are stored locally on your PC. 

 

 



 

 

76 | TEOS Manage user guide 

 
 

 

And selecting them by clicking the media file. After that click “open” and then click upload media. The 

media file will be uploaded to TEOS Manage. 

 

You can delete or view the media file by clicking on the buttons next to it. 
 
       Delete 
       User Rights 
       View 
 
Using the user rights you can set the rights another user has using the selected media file. Standard other 
users have rights unless you choose not to. 
 

External data 
 

For external data, you can provide feeds of external sources, including RSS feeds, XML feeds or Twitter feeds. 

RSS feeds are often used to provide content for third-party programs without 

formatting. You might also have HR software that lists your employees’ birthdays in XML, allowing you to easily 

display data on your screen. 

 

RSS Feed 
 

To add a feed click External data and then New datasource in the top right of this tab: 

 
 

In this example, we will add an RSS feed from CNN (http://rss.cnn.com/rss/edition_world.rss). First, we name 

our data source CNN and then select RSS/XML: 

 

http://rss.cnn.com/rss/edition_world.rss)
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Click Next and the following appears: 
 

 
 
Fill out the URL for your RSS/XML feed. Should the feed require Windows authentication, you can also fill out 

the username and password here. When you are done, click Save. The external data source is now set up and 

appears in your overview: 

 

 
 

From here, you can click the icons in front of the feed to edit your feed: 

• Edit - Lets you view and/or edit what you have entered in the above  
 steps. 

• Delete - Deletes your data source from the Designer. 

• View - Opens a new browser tab to show you the data in the specific  
 feed. 
 

Data modification 
 

• Modify - Lets you replace text from your datasource to another value  

you want. 
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An example for this would be a feed that shows the day of the week in English (Wednesday), but you want to 

show it in German (Mittwoch). In the left field, you would have to fill out Wednesday, to the right would be 

Mittwoch. 

 

Connecting calendars to the meeting room element or the MRA with External Data 

 
Office 365 Calendar 

 

You can add an Office 365 calendar to TEOS Signage creation or you can add it to the MRA. 

There are no additional settings needs in the management console of Office 365. 

 
MRA 

 

• Step 1: Click on “Device management” 

• Step 2: Click on the “Edit” button of the Professional BRAVIA you 

 want to use 

• Step 3: Click on the “Content” Tab 

• Step 4: Select your frame size (Bottom Half or Full Screen) 

• Step 5: Select Outlook in the “Content” pull down list 

• Step 6: Fill in your username and password 

• Step 7: Type in the name of the calendar that you want to publish eq.  

 “calendar” 

• Step 8: Click Save 

 
Now your calendar is ready for use. 

 

 

TEOS Content Creation 
 

• Step 1: Click on “Content Creation” 

• Step 2: Click on “External Data” 

• Step 3: Click on “New Datasource” and select Office 365 

• Step 4: Insert a Name for your calendar, for example “TEOS Calendar” 

• Step 5: Insert your username and password for the account eq. user@domain 

• Step 6: Select “Calendars” or “Rooms” depending on your configuration 

• Step 7: Click Save 

 
Please note that if you want to use a different calendar then the default one, you need to follow these 
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additional steps: 

 
• Step 1: Click on the “Edit” pencil in front of the item that you want to change 

• Step 2: Click “Next” 

• Step 3: Click “Save” 

• Step 4: Select your desired calendar. 

 
Now your calendar is ready for use. 
 

Exchange Server Calendar 
 

You can add an Exchange calendar to TEOS Signage creation or you can add it to the MRA. For both 

methods, it required that EWS is enabled on your company’s Exchange server. 

 
MRA 

 

To add the account to TEOS IT needs to enable the EWS URL that can be accessed from the TEOS Server, for 

example: https://mail.yourcompany.xxx/ews/exchange.asmx 

 
• Step 1: Click on “Device management” 

• Step 2: Click on the “Edit” button of the Professional BRAVIA you want to use for MRA 

• Step 3: Click on the Content Tab 

• Step 4: Select your frame size 

• Step 5: Select Exchange in the “Content” pull down list 

• Step 6: Fill in your username and password 

• Step 7: Type in the name of the calendar that you want to publish eq. “calendar” 

• Step 8: Click on “Save” Now your calendar is ready for use. 
 

Google Calendar 
 

First of all, you need to create an API key from google. Preferable is that you use one account who has rights on 

all the agenda’s that needs to be used with the meeting room-element. 

 
• Step 1: Browse to https://console.developers.google.com 

• Step 2: Login with the appropriate google account 

• Step 3: Click “create project” on the right side of the google dashboard 

• Step 4: Click the “create” button 

• Step 5: Type in your project name, for example “TEOS Meeting Room” 

• Step 6: Click on “Create” 

• Step 7: Click on “Library” on the left side 

• Step 8: Select the Google Calendar API and click “Enable” 

• Step 9: Click “Credentials” on the left side of the console 

• Step 10: Click on the “OAuth consent screen” in the top menu 

• Step 11: Insert a product name, for example “TEOS Calendar” and click save 

• Step 12: Click the “Create credentials” button and select OAuth client ID 
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• Step 13: Select “Web Application” and insert a name, for example TEOS Calendar Final step fill in the 
authorized redirect URL’s: 
 

• URL 1: http://YourTeosUrl.xxx/ AuthCallback/IndexAsync 
 

• URL 2: http://YourTeosUrl.xxx/3.5/authenticate Click “Create” 
 

Please note that you need to change the URL to your own TEOS URL 

 
After clicking, you will see the client ID and Secret that Google created for you. Copy these 

numbers as you will need them in the upcoming steps. 
 

Connecting the google account to your TEOS installation 

 
MRA 

 

Go to the device management page and edit the desired device with the proper license. Next, please navigate 

to the “Content” tab. In here, you can enter the desired frame size, set Content to Google and fill in the Client ID 

and Secret. 

You can now save the information. After this, press the preview icon in front of the device. The preview will 

take you to a Google authentication page. 

Allow this authentication and afterwards your account will be fully linked. 

 
TEOS Content creation 

 

Go to the Content creation menu. When the content creation is showing enter the direct URL: 

http://designer.teosmanage.com/3.5/pages/datasources.aspx?lang=en 

 
Click here on New Datasource -> fill in a name, select Google calendar and press Next -> Fill in your Client ID 

and Secret. After pressing “Save”, a pop-up will open. Log-in and allow the request to read calendar 

information. After allowing this, the connection has been made. 

 
 
  

http://yourteosurl.xxx/
http://yourteosurl.xxx/3.5/authenticate
http://designer.teosmanage.com/3.5/pages/datasources.aspx?lang=en
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